装逼爱好者

您正在访问位于非洲的夏威夷海岸附近的喜马拉雅山脉的富士山上的索马里域名网站!

1

Ubuntu系统开启root登陆权限

1.安装openssh 2.sudo -i切换到root用户 3.修改/etc/ssh/sshd_config文件 PermitRootLogin yes AllowUsers root #网上很多文章都少改了这行 4.重启ssh服务 service ssh restart

阅读全文

作者:装逼爱好者 | 分类:OS | 标签: ssh, ubuntu, root
0

FTP常见的报错信息

“426 Data connection closed, error decompressing data stream”信息,原因: 当上传文件大小为0的空文件时,系统会提示上传失败.实际该文件名在服务器已经创建了。解决办法: 这个错误是FlashFxp 客户端软件的误报错.实际文件已经上传上去了1.120 Service ready in nnn minutes. 服务在NNN时间内可用2.125 Data connection already open; transfer starting. 数据连接已经打开,开始传送数据.3.150 File status okay; about...

阅读全文

作者:装逼爱好者 | 分类:网站运维 | 标签: FTP, 错误提示
0
0

删除github的项目

前几周上传了下做的app的源码,后来发现源码中有太多错误,匆匆便上传了,之后想删掉一直找不到按钮,看了下help:https://help.github.com/articles/deleting-a-repository发现还是比较繁琐,大致步骤如下:1,登陆后点击中间的Repositories选项,然后点击进你的项目2,进去项目后如下图,点击右下角的settings3,进入settings页面后拖到最下方,可以看到有delete按钮,然后还等什么,点击一下4,点击delete this repository这个按钮后会弹出如下窗口,输入你的项目名称,点击下面的按钮就删除了PS:顺便贴...

阅读全文

作者:装逼爱好者 | 分类:网文资讯 | 标签: git, github
0

MySql常用命令总结

如果要对用户所用的登录终端进行限制,可以更新User表中相应用户的Host字段,在进行了以上更改后应重新启动数据库服务,此时登录时可用如下类似命令:mysql -uroot -p; mysql -uroot -p密码; mysql -h主机IP -u用户 -p密码; mysql 数据库名称 -u用户 -p; mysql 数据库名称 -u用户 -p密码;上面命令参数是常用参数的一部分,详细情况可参考文档。 1:使用SHOW语句找出在服务器上当前存在什么数据库:mysql> SHOW DATABASES;2:创建一个数据库MYSQLDATAmysql> CREATE DATABA...

阅读全文

作者:装逼爱好者 | 分类:网站运维 | 标签: mysql, 数据库
0

Centos6快速方便配置内核安装Xen

Xen安装配置过程中配置kernel比较难,没有足够经验就可能出现内核启动不起来 redhat有了自己家的孩子kvm后就带Xen玩了,rhl家族就fedora独自带着Xen在玩. 好在Centos有提供扩展源可以使用 官方地址 http://wiki.centos.org/HowTos/Xen/Xen4QuickStart安装也非常简单:第一步:导入扩展源#yum install centos-release-xen -y第二步:安装扩展源提供带Xen的内核#yum install kernel kernel-devel -y第三步:安装Xen扩展源提供的Xen版本是比较高,生产环境有时...

阅读全文

作者:装逼爱好者 | 分类:OS | 标签: linux, centos, xen
0

OpenVZ下guest OS无法修改时间解决办法

Xen和KVM虚拟化更改时区和时间都很简单,但openvz处于特殊的容器模式需要在上层的master host里面赋予权限才可以.Tips:一般情况运行ntpdate调整时间会出现Operation not permitted,具体样子如下# ntpdate time.example.com ntpdate[$pid]: step-systime: Operation not permitted在master host上操作以下命令# vzctl set [ctid] --capability sys_time:on --save # vzctl restart [ctid][ctid]...

阅读全文

作者:装逼爱好者 | 分类:OS | 标签: linux, openvz, 时间, 时区
0
0

rsync做断点续传

有时候直接用scp命令传送文件偶尔遇上中断了又得重来,scp是通过ssh和远程系统之间通讯时常用的文件拷贝工具。但 scp自身缺乏续传功能,如果传送大文件的过程中遭遇断连要重新开始传输,很令人头疼。我们可以借助rsync来做续传,用alias做rscp自定义命令或者直接用rsync带上参数都可以,如果常用的化可以加入 ~/.bashrc 中.alias rscp='rsync -v -v -P -e ssh'或者直接使用rsync -v -v -P -e ssh 【源数据位置】【目标数据位置】rsync 的工作原理类似p2p分块比较/传输,内建校验功能;所以这不仅是续传,因为传输过程中如...

阅读全文

作者:装逼爱好者 | 分类:OS,促销资讯,网站运维 | 标签: linux, ssh, shell, scp, rsync, 断点续传
0

安装mod_rpaf让在后端apache获取客户端IP

在前端服务器中可以使用X-Forwarded-For将客户端真实IP传递到后端,但apache无法直接处理需借助模块实现, stderr.net发布的mod_rpaf for Apache就是实现这个的一个东东。Linux 安装shell代码wget -c http://stderr.net/apache/rpaf/download/mod_rpaf-0.6.tar.gz tar xvfz mod_rpaf-0.6.tar.gz cd mod_rpaf-0.6 /usr/sbin/apxs -i -c -n mod_rpaf-2.0.so mod_rpaf-2.0.c cat >>/et...

阅读全文

作者:装逼爱好者 | 分类:OS,网站运维 | 标签: linux, apache, rpaf, 前后端, httpd